Go Back   RCLargeScale.com > Large Scale Brand Specific Tech > HPI Baja 5B

Notices

Loading

Thread: Engine starting problem

Reply
 
LinkBack Thread Tools Display Modes
Old 07-20-2017, 06:50 AM   #1
Newbie
 
Join Date: Oct 2008
Posts: 5
Default Engine starting problem

Hi,

I have a cy26rc engine and have issue in starting the engine.
Each and every time I need to put the choke lever down and then when it gives a small start, then I put the coke back and engine start without any issue. After 10- 15 mins I try to start it won't start. I need to do the same process again for putting the choke down and start.

Kindly let me know what might be the issue.. thanks in advance
samfire18 is offline   Reply With Quote
Sponsored Links
Old 07-20-2017, 09:54 AM   #2
Addict
 
Join Date: Feb 2012
Location: Huntington
Posts: 325
Default Engine starting problem

Could be a lot of little things
Bad fuel line pinhole right where it goes on the carb and it loses the prim
Or low speed set to lean will make them hard to start also
If it Idols real fast it's lean so slow it down and see if that helps
Use the low speed jet to slow it down not the idle stop screw
Check that the carb manifold is tight to the motor they suck around the pulse hole that is use to pump fuel

Last edited by Nitrocat; 07-20-2017 at 09:58 AM.
Nitrocat is offline   Reply With Quote
Old 07-21-2017, 09:17 AM   #3
Addict
 
Join Date: Nov 2014
Location: USA
Posts: 448
Garage
Default Re: Engine starting problem

Quote:
Originally Posted by samfire18 View Post
Hi,

I have a cy26rc engine and have issue in starting the engine.
Each and every time I need to put the choke lever down and then when it gives a small start, then I put the coke back and engine start without any issue. After 10- 15 mins I try to start it won't start. I need to do the same process again for putting the choke down and start.

Kindly let me know what might be the issue.. thanks in advance
Make sure the carb is set to factory start settings and the idle screw too. Try a new plug $3 and or new carb kit K20-wat $4 and see if the problem goes away. I suspect the oil mix is too rich and or the filter screen inside the carb is bad.

Last edited by king quarterscale; 07-21-2017 at 09:28 AM.
king quarterscale is online now   Reply With Quote
Reply


Engine starting problem - Similar Threads
Thread Thread Starter Forum Replies Last Post
starting a hot 5t engine losirevo2 Engine & Exhaust 2 06-26-2011 07:32 PM
Starting and tuning your engine video 5B Driver Engine & Exhaust 7 02-21-2010 10:04 AM
Help engine not starting!!! silverbaja HPI Baja 5B 4 05-01-2009 07:29 PM
Help (My Baja Engine Not Starting) woooow77 Engine & Exhaust 3 01-01-2009 02:22 PM
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 07:41 AM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.